Thread (2 messages) flat view 2 messages, 2 authors, 2016-06-15

Re: test-mergesort conflict with stdlib.h

From: Brian Gernhardt <hidden>
Date: 2016-06-15 22:53:37

Possibly related (same subject, not in this thread)

On Apr 17, 2012, at 2:06 PM, Junio C Hamano wrote:
Junio C Hamano [off-list ref] writes:
quoted
Unfortunate.  OS X shouldn't contaminate the user namespace by adding such
names in stdlib.h (which incidentally has qsort()), but the damage is done
already, so I am not opposed to rename it to llist_mergesort() or something.
Something like this.  While we are touching the code, let's add some
documentation to the header.

commit.c         |    4 ++--
mergesort.c      |    8 ++++----
mergesort.h      |   16 ++++++++++++----
test-mergesort.c |    2 +-
4 files changed, 19 insertions(+), 11 deletions(-)
This is basically identical to what I was going to send and it does, in fact, fix my build problem.

Thanks,
~~ Brian Gernhardt
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help