Re: push.default: current vs upstream
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:53:33
Matthieu Moy [off-list ref] writes:
Junio C Hamano [off-list ref] writes:quoted
Jeff King [off-list ref] writes:quoted
On Sat, Apr 07, 2012 at 09:49:47AM +0200, Michael Haggerty wrote: ...quoted
If "push.default" is not set, then have it default to "beginner" mode.I would be fine with that (I've suggested it elsewhere in the thread, though I think I stole the idea originally from you. Speaking of going in circles. :) ).This makes the first priority for 1.7.10 cycle to come up with a solid implementation of the "beginner" mode, I guess.I guess so. I found the idea relevant the first time it came in the discussion, and I'm starting to get really convinced that this is the way to go. And if we're wrong, it will be much easier to migrate to either "current" or "upstream" later. No time to code this right now, but I may come up with a patch in a few days. Any idea on the real name? I'd call it "safeUpstream" or "safeCurrent", but that's probably by lack of a better name.
I'd say "simple" ;-)