Re: [PATCH 2/3] diff: refactor the word-diff setup from builtin_diff_cmd
From: Junio C Hamano <hidden> Date: 2016-06-15 22:53:18
Thomas Rast [off-list ref] writes:
Quite a chunk of builtin_diff_cmd deals with word-diff setup, defaults
and such. This makes the function a bit hard to read, but is also
asymmetric because the corresponding teardown lives in free_diff_words_data
already.
Yay! "A bit hard to read" is a gross understatement ;-)
Whether the series fixes a bug of not, this alone makes the patch
worthwhile to look.
Thanks.