Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCH v4 5/5] http: rename HTTP_REAUTH to HTTP_RETRY

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:53:18

Nelson Benitez Leon [off-list ref] writes:
After adding the proxy authentication support in
http, the semantics of HTTP_REAUTH changed more to
a retry rather than a re-authentication, so we
rename it to HTTP_AUTH_RETRY.

Signed-off-by: Nelson Benitez Leon <redacted>
---
Ok this is a new 5/5 patch that have HTTP_AUTH_RETRY as
Junio suggested, is responding with this patch good or
do I need to send a new re-roll just for this?
Heh, HTTP_AUTH_RETRY was not something I suggested ;-) The name comes from
your http://mid.gmane.org/4F5F41FF.4000204@seap.minhap.es message.

Regarding whether to re-send everything or only a selected subset, please
follow your best judgement, like you did this time.

In general, when you know that the participants in the discussion are
keeping closer eyes on the progress of the series, and they are likely to
understand what you mean when you say "I am replacing the last one in the
v3 series I sent earlier with this patch" when you send "[PATCH v4 5/5]",
it is appropriate to send only the updated one(s).

It makes only two small differences if I am or I am not among the
participants in the discussion.

 - When I happen to be involved in a topic and keeping closer eyes on it,
   an earlier iteration of it is likely to appear on 'pu', so you have one
   more clue to tell if it is OK to send just an update, compared to a
   series that is discussed only on the list without anybody tracking the
   most recent state of the series.

 - When I am not involved in a discussion, often I am sitting on the
   sideline (a recent example is the topic around svn-fe/fast-import
   regarding "ls" command on an empty path), letting the stakeholders in
   the series figure out the details and waiting for the final outcome of
   the discussion [*1*].  For such a topic, I may request a full resend of
   the final version when it is time for me to queue it.

Thanks.  I replaced the corresponding patch with this, after fixing the
subject line.

[Footnote]

*1* This happens when I have more confidence in them than in myself to
judge the best direction for the series.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help