Re: [PATCH v4 5/5] http: rename HTTP_REAUTH to HTTP_RETRY
From: Jeff King <hidden>
Date: 2016-06-15 22:53:18
On Tue, Mar 13, 2012 at 10:51:33AM -0700, Junio C Hamano wrote:
quoted
On 03/12/2012 09:06 PM, Junio C Hamano wrote:quoted
Whatever new token you use, please keep AUTH as a substring of it. We may want to retry a request to deal with intermittent failures on the server side or the network between us and the server; HTTP_RETRY would be a good name to signal such condition after we see a failure response from the library.HTTP_REAUTH and HTTP_AUTH_RETRY seems like the same thing, so imo not deserving the rename, maybe Jeff can suggest a better name as he was who suggest the rename.Either has AUTH as a substring in it, and leaves a door open for us to later introduce HTTP_RETRY to tell the machinery that drives cURL library to retry the request, so in that sense I am OK with either, but as your log message said, we want to make it clear that this is not about doing the authentication again (re-auth) but retrying the authentication, so HTTP_AUTH_RETRY would be more logical name.
I suggested RETRY because that is all the caller needs to know: the http_request machinery said "please call me again". Keep in mind that this is a private interface within http.c, and this return code should never make it out at all. Nor is it something anybody else would feed us. I am half-tempted to suggest refactoring it to return the actual error code, and let the caller handle 401 and 407. That would be more readable overall, I think. But it's a little complicated, because getting the exact answer depends on the curl handle, which is local to http_request, and I don't want to hold Nelson's actual feature improvement hostage to such refactoring. -Peff