Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCH 2/2] Support Out-Of-Tree Valgrind Tests

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:53:14

"David A. Greene" [off-list ref] writes:
Ok, I see.  So TEST_DIRECTORY is supposed to point to the "official"
location of git's tests and testing support files.  That wasn't clear to
me.
That is how I read the intent of what test-lib.sh does. I do not
think it has much to do with official-ness, but more about where you
find pieces of the framework from (e.g. diff-lib.sh, lib-gpg.sh,
etc.)
I think naming is a big issue here.  Perhaps TEST_DIRECTORY needs a
better name, something like GIT_TEST_SUPPORT or such?
I do not think so; the biggest problem I see is that nobody
documented these variables like Thomas did in the previous message
we saw in this thread (and Thomas knew more about them than all
because he added t/perf/ recently and had to play with these
variables).

Once the roles of variables are well understood, I do not think it
is worth renaming the existing uses.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help