On Wed, 1 Feb 2012, Junio C Hamano wrote:
Junio C Hamano [off-list ref] writes:
quoted
Nicolas Pitre [off-list ref] writes:
quoted
quoted
+static int find_pack_entry_1(const unsigned char *sha1,
+ struct packed_git *p, struct pack_entry *e)
This looks all goot but the name. Pretty please, try to find something
that is more descriptive than "1". Suggestions:
"find_pack_entry_lookup", "find_pack_entry_inner", etc.
Perhaps "find_pack_entry_in_pack(sha1, e, p)"?
That would go well with the caller "find_pack_entry(sha1, e)".
I amended 1/2 (and adjusted 2/2 to match) to call it fill_pack_entry.
Will push out the result tonight.
Looks fine to me.
Nicolas