Thread (3 messages) 3 messages, 3 authors, 2016-06-15

Re: [PATCH] Revert "gitweb: Time::HiRes is in core for Perl 5.8"

flat view

From: Ævar Arnfjörð Bjarmason <hidden>
Date: 2016-06-15 22:52:52

On Fri, Jan 27, 2012 at 21:44, Junio C Hamano [off-list ref] wrote:
       if (defined $t0)

If you go this route, even though tee-zero, the beginning of the
time, is a good name for the variable, you may want to rename it to
avoid confusing readers who might take it as a temporary variable
#0.
<trivia>

Personally I'd have written it as $START_TIME, but as a bit of Perl
trivia you might not realize $t0 is a commonly used and undestood
variable for dealing with a start time in Perl in the same way that
`i` is common for dealing with array indexes in C.

I.e. someone used to Perl will immediately think "oh that's the start
time" having seen it hundreds of times before, but someone not used to
Perl will go "what's this t-zero thing?".

Meanwhile some Lisp programmer is wondering what the hell "i" means in
your C for-loops, iterator? :)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help