[PATCH 6/3] revert: remove --reset compatibility option
From: Jonathan Nieder <hidden>
Date: 2016-06-15 22:52:31
Subsystem:
the rest · Maintainer:
Linus Torvalds
Remove the "git cherry-pick --reset" option, which has a different
preferred spelling nowadays ("--quit"). Luckily the old --reset name
was not around long enough for anyone to get used to it.
Signed-off-by: Jonathan Nieder <redacted>
---
Thanks for reading.
builtin/revert.c | 3 ---
t/t3510-cherry-pick-sequence.sh | 4 ++--
2 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/builtin/revert.c b/builtin/revert.c
index 70a5fbb6..0c61668b 100644
--- a/builtin/revert.c
+++ b/builtin/revert.c@@ -154,9 +154,6 @@ static void parse_args(int argc, const char **argv, struct replay_opts *opts) OPT_STRING(0, "strategy", &opts->strategy, "strategy", "merge strategy"), OPT_CALLBACK('X', "strategy-option", &opts, "option", "option for merge strategy", option_parse_x), - { OPTION_BOOLEAN, 0, "reset", &remove_state, NULL, - "alias for --quit (deprecated)", - PARSE_OPT_HIDDEN | PARSE_OPT_NOARG }, OPT_END(), OPT_END(), OPT_END(),
diff --git a/t/t3510-cherry-pick-sequence.sh b/t/t3510-cherry-pick-sequence.sh
index 63297ad6..f28a4e8a 100755
--- a/t/t3510-cherry-pick-sequence.sh
+++ b/t/t3510-cherry-pick-sequence.sh@@ -94,7 +94,7 @@ test_expect_success '--quit cleans up sequencer state' ' test_path_is_missing .git/sequencer ' -test_expect_success 'cherry-pick --reset (another name for --quit)' ' +test_expect_success '--quit keeps HEAD and conflicted index intact' ' pristine_detach initial && cat >expect <<-\EOF && OBJID
@@ -105,7 +105,7 @@ test_expect_success 'cherry-pick --reset (another name for --quit)' ' :000000 100644 OBJID OBJID A unrelated EOF test_must_fail git cherry-pick base..picked && - git cherry-pick --reset && + git cherry-pick --quit && test_path_is_missing .git/sequencer && test_must_fail git update-index --refresh && {
--
1.7.8.rc3