David Aguilar [off-list ref] writes:
quoted
-void obstack_free (struct obstack *__obstack, void *__block);
+void obstack_free (struct obstack *obstack, void *block);
Tiny nit: I know it's just a declaration but would it be advisable to
drop the variable names altogether here?
I agree. In general it is easier to read if parameter names to a function
declaration is omitted, especially if it is clear from their types what
they mean [*1*]. And in this case, it is.
Tested-by: David Aguilar <redacted>
Thanks.
[Footnote]
*1* It is Ok to spell them out in a case like this:
int copy(char *dst, const char *src, size_t);
You do not have to, as "char *" vs "const char *" makes it clear which one
is which.