On Fri, Jun 10, 2011 at 10:15 PM, Junio C Hamano [off-list ref] wrote:
The size of objects we read from the repository and data we try to put
into the repository are represented in "unsigned long", so that on larger
architectures we can handle objects that weigh more than 4GB.
shouldn't this be "size_t" instead of "unsigned long"? "unsigned long"
is 32bit on Win64, whereas size_t is 64bit:
http://msdn.microsoft.com/en-us/library/s3f49ktz(v=vs.80).aspx
http://msdn.microsoft.com/en-us/library/aa384083(VS.85).aspx