Thread (11 messages) flat view 11 messages, 4 authors, 2016-06-15

Re: [PATCH 1/2] config: define and document exit codes

From: Michael J Gruber <hidden>
Date: 2016-06-15 22:51:15

Thiago Farina venit, vidit, dixit 17.05.2011 17:46:
On Tue, May 17, 2011 at 12:38 PM, Michael J Gruber
[off-list ref] wrote:
quoted
The return codes of git_config_set() and friends are magic numbers right
in the source. #define them in cache.h where the functions are declared,
Why defining them on cache.h? Just because the functions are declared
there? Is this a good reason? I think this pollute even more the
cache.h and these constants are not used outside of config.c. So I'd
move them back onto config.c. Maybe it's fine as is though.
Because, potentially, they are used by callers of these external
functions. It's the interface declaration. And in fact, 2/2 creates such
a use.

Michael
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help