Nguyễn Thái Ngọc Duy [off-list ref] writes:
[PATCH 1/5] Rename functions in preparation for get_pathspec() restructure
I figure I cannot bring all commands to the new get_pathspec() at
once and remove the old one. So instead I rename the old one so that
we can have both implementations running in parallel.
Horribly bad move. Keep the old one running under the same name, and keep
the unconverted ones working the same way without new features. Introduce
a new infrastructure under a new API function name.
Otherwise you cannot merge in new calles that expect the old
get_pathspec() behaviour.