Johan Herland [off-list ref] writes:
In order to make this more understandable to the user, we rename the
push.default == 'tracking' option to push.default == 'upstream'.
While we're there, shouldn't we also rename 'branch.<remote>.merge' to
'branch.<remote>.upstream'?
It has a bit more consequences, since external porcelains/scripts are
likely to call "git config branch.foo.merge", and would be broken by
such change. But maybe 1.8.0 is the time for this kind of things.
--
Matthieu Moy
http://www-verimag.imag.fr/~moy/