Jared Hance [off-list ref] writes:
Notes/Complications:
- I'm not sure whether the option should be merge.defaultUpstream
or merge.defaultToUpstream
Probably the latter.
- Should [remotes] be changed to [branches]? I felt like it was
a completely different change and didn't belong in the patch series.
Perhaps at the beginning (just like your 1/3 refactoring) or at the end as
a separate patch?
- I left one of the ifs with unnecessary braces for clarity because
of a nested if-else: is this the preferred style?
If you are talking about the one at @@ -1017,9 +1023,13 @@, it looks fine
to me. The new "else" you added to @@ -525,6 +527,8 @@ may probably want
to start on the same line as closing "}" of the "if", though. IOW, like
this:
if (cond) {
...
} else {
...
}
not like this:
if (cond) {
...
}
else {
...
}
But other than that looks reasonable.
Thanks.