Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCH] commit: Add commit_list prefix to reduce_heads function.

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:50:11

Thiago Farina [off-list ref] writes:
quoted
"insert-by-date" does not say _why_ you want things to be inserted by date
(neither "sort-by-date").  They are pretty generic looking names for any
function that deal with a list of elements that record date.  It makes
sense to anticipate there will be many other such functions that deal with
different kinds of lists that hold date-recording things, and naming one
of them "this deals with list of COMMITS" by saying "commit_list_foo"
makes quite a lot of sense, as "insert-by-date" does not give sufficient
information to the reader.
That makes sense to me. And clarified why the complain at all. And you
are right.
Actually I think s/insert_by_date/commit_list_insert_by_date/ is a
mistake.  Something like insert-commit-by-date would be more appropriate.
Similarly for s/sort_by_date/commit_list_sort_by_date/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help