Thread (5 messages) flat view 5 messages, 2 authors, 2016-06-15

Re: [PATCH] commit: Append commit_list prefix in two function names.

From: Jonathan Nieder <hidden>
Date: 2016-06-15 22:50:07

Thiago Farina wrote:
On Sun, Nov 14, 2010 at 7:19 PM, Jonathan Nieder [off-list ref] wrote:
quoted
This gives the oft-used insert_by_name() function a fairly long name:

       commit_list_insert_by_name

The proposed name is long enough to be unwieldly.  It might have
the virtue of fitting better with some of the commit_list lib:

       commit_list_count
       commit_list_insert
       free_commit_list

Compare:

       sort_by_date
       pop_most_recent_commit
       sort_in_topological_order
       pop_commit
I don't understand what you are arguing here. Is about the size of
"commit_list_insert_by_name"? I don't care about it's size,
For code clarity, length of function names can matter...
I just
want to make it consistent by adding commit_list in the functions that
are part of the commit_list API.
... though this consideration is probably more important.
quoted
Perhaps this change would work better if some of the others were
renamed at the same time?
I don't think so, this would increasing the size of the change and
make it less readable.
Even if split up into multiple patches?  I don't think it makes much
sense to say "functions in the commit_list API all start with
commit_list_" while at the same time leaving half of the functions in
the commit_list API without that suffix.

By the way, how did this come up?  Presumably some particular code
was confusing?  If so, that information could be useful as an example
in the log message.

Regards,
Jonathan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help