Re: What's cooking in git.git (Nov 2010, #01; Tue, 9)
flat view
From: Erik Faye-Lund <hidden>
Date: 2016-06-15 22:50:00
On Tue, Nov 9, 2010 at 8:53 PM, Junio C Hamano [off-list ref] wrote:
Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' while commits prefixed with '+' are in 'next'. The ones marked with '.' do not appear in any of the integration branches, but I am still holding onto them. -------------------------------------------------- [New Topics] * dk/maint-blame-el (2010-05-25) 1 commit (merged to 'next' on 2010-11-05 at 8456c66) + git-blame.el: Add (require 'format-spec) * ef/mingw-daemon (2010-11-04) 16 commits - daemon: opt-out on features that require posix - daemon: make --inetd and --detach incompatible - daemon: use socklen_t - mingw: use poll-emulation from gnulib - mingw: import poll-emulation from gnulib - daemon: get remote host address from root-process - Improve the mingw getaddrinfo stub to handle more use cases - daemon: use full buffered mode for stderr - daemon: use run-command api for async serving - mingw: add kill emulation - mingw: support waitpid with pid > 0 and WNOHANG - mingw: use real pid - inet_ntop: fix a couple of old-style decls - compat: add inet_pton and inet_ntop prototypes - mingw: implement syslog - mingw: add network-wrappers for daemon Will merge to 'next'.
Thanks. On Tue, Nov 9, 2010 at 8:53 PM, Junio C Hamano [off-list ref] wrote:
* yd/dir-rename (2010-10-29) 5 commits - Allow hiding renames of individual files involved in a directory rename. - Unified diff output format for bulk moves. - Add testcases for the --detect-bulk-moves diffcore flag. - Raw diff output format for bulk moves. - Introduce bulk-move detection in diffcore.
This series currently breaks the Windows build of 'pu', as we lack memrchr there. Jonathan Nieder posted a patch (<20101015051750.GA21830@burratino>) that adds a memrchr implementation. This should probably either be rebased on top of that patch, or re-rolled. While 'pu' not building on Windows might not be a big deal, it's worth keeping in mind before merging it further.
* ab/i18n (2010-10-07) 161 commits - po/de.po: complete German translation - po/sv.po: add Swedish translation - gettextize: git-bisect bisect_next_check "You need to" message
<...>
- tests: use test_cmp instead of piping to diff(1) - t7004-tag.sh: re-arrange git tag comment for clarity Will merge to 'next' to see what happens; it is getting ridiculously painful to keep re-resolving the conflicts with other topics in flight, even with the help with rerere.
Hmmm, this is a bit more annoying IMO - this currently breaks in msysgit, due to lack of gettext and NO_GETTEXT not working properly. Ævar is aware of this (AANLkTiny+NmXew6UxjNMO+o75=CxxWm9iVRMRxs0LyTJ@mail.gmail.com), but haven't fixed it yet. I do have the patches needed to get a gettext in msysgit, so it's not a very big deal to me. But are you sure that this makes this series ready for 'next'?