This is my first patch set to mail to this list, so I hope I get things right...
This patch set tries to make git-rebase.sh a bit more readable and to make it a
bit easier to extend. The only change in behavior that I know I have introduced
(in PATCH 2) is that "git rebase (--continue | --skip)" when an empty
"$GIT_DIR/rebase-merge" exists now gives slightly fewer error messages while
trying to cat files in that directory. The only reason for this change was to
make it better aligned with the behavior when an empty
"$GIT_DIR/rebase-apply" exists.
These patches are related to, but different from, the mail I sent about
extracting common code between git-rebase.sh and git-rebase--interactive.sh (see
http://thread.gmane.org/gmane.comp.version-control.git/160517). I would like to
base that work on the current patch set.
git-rebase.sh | 148 +++++++++++++++++++++++++--------------------------------
1 files changed, 65 insertions(+), 83 deletions(-)