On Thu, Aug 5, 2010 at 14:16, Jonathan Nieder [off-list ref] wrote:
Bert Wesarg wrote:
quoted
On Thu, Aug 5, 2010 at 13:17, Jonathan Nieder [off-list ref] wrote:
quoted
quoted
+static inline int ll_opt_favor(int flag)
+{
+ return (flag & LL_OPT_FAVOR_MASK) >> LL_OPT_FAVOR_SHIFT;
+}
+
+static inline int create_ll_flag(int favor)
+{
+ return ((favor << LL_OPT_FAVOR_SHIFT) & LL_OPT_FAVOR_MASK);
+}
+
[...]
quoted
Or flavor_to_ll_flag()
and ll_flag_to_flavor().
Sounds reasonable. (Well, except this is “favor” as in “favor our
side” or “favor their side” rather than “flavor of the month”.) Patch?
Sorry for this typo. Do you really want a squash patch for this renaming?
Bert