Dan McGee [off-list ref] writes:
On Arch Linux, we keep the original 'httpd' name for the exectuable and
don't rename it or the path to the modules.
Sorry, but I cannot parse the last 6 words here.
Remove some of these assumptions
and add the httpd name in where it may be required.
...
resolve_full_httpd () {
case "$httpd" in
- *apache2*|*lighttpd*)
+ *apache2*|*lighttpd*|*httpd*)
+ # yes, *httpd* covers *lighttpd* above, but it is there for clarity
That may make things work better on Arch but I wonder if there are
platforms that allow users to point at their favorite, non-Apache, http
server with a canonical name "httpd" that gets broken by this change. Am
I being too paranoid?
Other two patches looked very sane. Thanks.