Junio C Hamano [off-list ref] writes:
It probably is a good idea to switch aliases to start at the $cwd in 1.8.0
(or perhaps one major release after it), and using a notation that is more
descriptive, something like "!(cwd)" vs "!(root)", may give us a better
transtion strategy than casting cryptic "!!" in the stone.
I like this: Allow !(cwd) and !(root) today, with !(root) being just
like "!", and change plain "!" to mean !(cwd) in a future major
release.
If other people have ideas for other features, the syntax can also be
extended to !(cwd,some-option) or so.
--
Matthieu Moy
http://www-verimag.imag.fr/~moy/