Re: [PATCH] Rename ONE_FILESYSTEM to DISCOVERY_ACROSS_FILESYSTEM
From: Matthieu Moy <hidden>
Date: 2016-06-15 22:48:33
Junio C Hamano [off-list ref] writes:
If a missing ONE_FILESYSTEM defaults to true, the only users who set this variable set it to false to tell git not to limit the discovery to one filesystem; there are too many negations in one sentence to make a simple panda brain dizzy.
Right. + an explicit respository directory set via 'GIT_DIR' or on the While you're there, you can spell respository as "repository" ;-).
quoted hunk
diff --git a/setup.c b/setup.c index d290633..5a26b5b 100644 --- a/setup.c +++ b/setup.c@@ -392,7 +392,7 @@ const char *setup_git_directory_gently(int *nongit_ok) * etc. */ offset = len = strlen(cwd); - one_filesystem = git_env_bool("GIT_ONE_FILESYSTEM", 0); + one_filesystem = !git_env_bool("GIT_DISCOVERY_ACROSS_FILESYSTEM", 0); if (one_filesystem) { if (stat(".", &buf)) die_errno("failed to stat '.'");
I guess you still have one instance of GIT_ONE_FILESYSTEM a little below in the error message: "Stopping at filesystem boundary since GIT_ONE_FILESYSTEM is true." which should become "Stopping at filesystem boundary since GIT_DISCOVERY_ACROSS_FILESYSTEM\n" "is not set." or so. -- Matthieu Moy http://www-verimag.imag.fr/~moy/