[PATCH v2 4/4] Refactoring: remove duplicated code from builtin-checkout.c and merge-recursive.c
From: Michael Lukashov <hidden>
Date: 2016-06-15 22:48:17
Subsystem:
the rest · Maintainer:
Linus Torvalds
The following functions are duplicated: fill_mm Signed-off-by: Michael Lukashov <redacted> --- builtin-checkout.c | 18 ------------------ merge-recursive.c | 2 +- merge-recursive.h | 3 +++ 3 files changed, 4 insertions(+), 19 deletions(-)
diff --git a/builtin-checkout.c b/builtin-checkout.c
index 5277817..e53e857 100644
--- a/builtin-checkout.c
+++ b/builtin-checkout.c@@ -128,24 +128,6 @@ static int checkout_stage(int stage, struct cache_entry *ce, int pos, (stage == 2) ? "our" : "their"); } -/* NEEDSWORK: share with merge-recursive */ -static void fill_mm(const unsigned char *sha1, mmfile_t *mm) -{ - unsigned long size; - enum object_type type; - - if (!hashcmp(sha1, null_sha1)) { - mm->ptr = xstrdup(""); - mm->size = 0; - return; - } - - mm->ptr = read_sha1_file(sha1, &type, &size); - if (!mm->ptr || type != OBJ_BLOB) - die("unable to read blob object %s", sha1_to_hex(sha1)); - mm->size = size; -} - static int checkout_merged(int pos, struct checkout *state) { struct cache_entry *ce = active_cache[pos];
diff --git a/merge-recursive.c b/merge-recursive.c
index cb53b01..5999ae2 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c@@ -599,7 +599,7 @@ struct merge_file_info merge:1; }; -static void fill_mm(const unsigned char *sha1, mmfile_t *mm) +void fill_mm(const unsigned char *sha1, mmfile_t *mm) { unsigned long size; enum object_type type;
diff --git a/merge-recursive.h b/merge-recursive.h
index be8410a..ccc4002 100644
--- a/merge-recursive.h
+++ b/merge-recursive.h@@ -2,6 +2,7 @@ #define MERGE_RECURSIVE_H #include "string-list.h" +#include "xdiff/xdiff.h" struct merge_options { const char *branch1;
@@ -53,4 +54,6 @@ int merge_recursive_generic(struct merge_options *o, void init_merge_options(struct merge_options *o); struct tree *write_tree_from_memory(struct merge_options *o); +void fill_mm(const unsigned char *sha1, mmfile_t *mm); + #endif
--
1.7.0.1571.g856c2