Thread (3 messages) flat view 3 messages, 3 authors, 2016-06-15

Re: [PATCH] Typofixes outside documentation area

From: Thomas Rast <hidden>
Date: 2016-06-15 22:48:10

On Thursday 04 February 2010 06:31:05 Junio C Hamano wrote:
quoted hunk ↗ jump to hunk
diff --git a/levenshtein.h b/levenshtein.h
index 0173abe..4105bf3 100644
--- a/levenshtein.h
+++ b/levenshtein.h
@@ -2,7 +2,7 @@
 #define LEVENSHTEIN_H
 
 int levenshtein(const char *string1, const char *string2,
-	int swap_penalty, int substition_penalty,
+	int swap_penalty, int substitution_penalty,
 	int insertion_penalty, int deletion_penalty);
 
 #endif
To save others the trouble of looking it up, too:

This does change the name of the parameter, but it's only the
declaration.  The actual definition of the function starts with

	int levenshtein(const char *string1, const char *string2,
			int w, int s, int a, int d)
	{

so it doesn't need a similar rename, and no uses of the parameter are
affected.

AFAICS all other changes are only in comments or strings and should be
safe.

-- 
Thomas Rast
trast@{inf,student}.ethz.ch
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help