Re: [RFC PATCH] Record a single transaction for conflicting push operations
From: Karl Wiberg <hidden>
Date: 2016-06-15 22:47:55
On Mon, Dec 21, 2009 at 12:21 AM, Catalin Marinas [off-list ref] wrote:
2009/12/19 Karl Wiberg [off-list ref]:quoted
Better. But couldn't you remove the update function completely and just inline the code in it, since it's called immediately?Of course, I tried, but couldn't get it to work. I get HEAD and top not equal unless I call update() between _TransPatchMap and self.__halt(). For the non-conflicting case we need to call update before or after this "if merge_conflict". One solution is to split the "if merge_conflict" in two but maybe you have a better idea.
Yes, duplicating the conditional was what I had in mind. But if you don't find it to improve the readability of the code (as compared to having a function), I certainly won't insist. Thanks for working on this. By the way, you do realize there's another command that requires two steps to undo completely: refresh? And that one is harder to get out of---undoing it all in one step would mean throwing away the updates to the patch. -- Karl Wiberg, kha@treskal.com subrabbit.wordpress.com www.treskal.com/kalle