Re: What's cooking in git.git (Oct 2009, #01; Wed, 07)
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:47:29
Jakub Narebski [off-list ref] writes:
Junio C Hamano [off-list ref] writes:quoted
-------------------------------------------------- [New Topics]quoted
* jn/gitweb-patch (2009-09-30) 1 commit - gitweb: Do not show 'patch' link in 'commit' view for merges jk: After some comments with Jakub, I think the code is right but he promised a re-roll with more in the commit message.Not only better commit message, but a more complete patch as well.
Ok; I'll wait.
quoted
* mr/gitweb-snapshot (2009-09-26) 2 commits - gitweb: append short hash ids to snapshot files - gitweb: check given hash before trying to create snapshot jk: He posted a v5 of his series. I didn't look at it closely, but Jakub ack'd it.... In short: first patch is a go, second needs more work.
Ok; I'll merge fdb0c36 (gitweb: check given hash before trying to create snapshot, 2009-09-26) to 'next'.
quoted
* jc/pretty-lf (2009-10-04) 1 commit - Pretty-format: %[+-]x to tweak inter-item newlines I am not happy with this one yet. I am contemplating to introduce a new syntax "%[magic(param)<anything>%]" to generalize expressions of this and line wrapping features in an extensible way. ...So... it is magic %[...%] or %{...} or %{...%}?
The escape does not matter. %() is fine, too. It is non-essential for the purpose of the upcoming release so I have backburnered coming up with and thinking the details through.
quoted
-------------------------------------------------- [Cooking]quoted
* jn/gitweb-show-size (2009-09-07) 1 commit - gitweb: Add 'show-sizes' feature to show blob sizes in tree viewWhat this one requires (beside better name for a feature)?
Name before 'next', and then the usual cooking, I guess.
quoted
* jn/gitweb-blame (2009-09-01) 5 commits ... Ajax-y blame.I reordered patches so JSMIN one is first (as it is less controversial), but the 'create blame_incremental links' one needs more work.
Ok; I'll wait. Thanks.