Thread (7 messages) flat view 7 messages, 4 authors, 2016-06-15

Re: [PATCH] Trivial fix: Make all the builtin usage strings to use the same pattern.

From: Thiago Farina <hidden>
Date: 2016-06-15 22:47:26

On Mon, Sep 21, 2009 at 1:09 PM, Johannes Sixt [off-list ref] wrote:
Thiago Farina schrieb:
quoted
They follow the pattern of file name:
File name pattern: builtin-command-name.c
Usage string pattern: builtin_command_name_usage
Well, file names are not so constant: every now and then an external
command is turned into a builtin (and the filename is changed), and we
have even seen that a builtin was turned into an external command.
Moreover, some commands are implemented in the same file, for example 'git
log' and 'git show'. How about naming the variable after the command name?
E.g.:

command:  git cat-file
variable: git_cat_file_usage
That sounds good, I will follow this pattern in the next patch. So all
existing builtin_command_name_usage will be changed to
git_command_name_usage, command_name_usage to git_command_name_usage,
etc.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help