Shawn O. Pearce wrote:
Nasser Grainawi [off-list ref] wrote:
quoted
Should PatchId be a class on its own, or just a method within the Patch
class?
Hmm, maybe a method on Patch is reasonable.
Going down this route, I'd add a few things to Patch.
patchId would be a private field (of type ObjectId?)
getPatchId would be a public method that returns patchId
and then likely a private method (computePatchId?) that actually
generates the patchId
This way any method in Patch that would potentially change a Patch
object's patch-id would call computePatchId before it returns.
Thoughts?