From: Michael J Gruber <hidden> Date: 2016-06-15 22:46:57
Bert Wesarg venit, vidit, dixit 15.06.2009 22:45:
Signed-off-by: Bert Wesarg <redacted>
---
On Mon, Jun 15, 2009 at 09:49, Michael J Gruber[off-list ref] wrote:
quoted
Jim Meyering venit, vidit, dixit 14.06.2009 21:46:
quoted
* builtin-remote.c (get_one_entry): Use xmalloc, not malloc.
Learning something new with every patch... Sorry, Junio; thanks, Jim!
One more reason to re-use existing string handling functions.
Well, when we discussed this before v2 I asked for guidance about
strbuf, esp. regarding the issue of allocating/freeing. From your patch
I infer that "strbuf_detach" is what I was looking for. (And yes, it is
in the api doc where I overlooked it.)
For whatever reason, your patch does not apply (am) here on top of next
+ Jim's patch. Given the context (xmallocs), it looks like it's against
something + Jim's patch. OTOH: 709f8a6 show's a get_one_entry with
mallocs. Did you hand edit the diff?
Michael
For whatever reason, your patch does not apply (am) here on top of next
+ Jim's patch. Given the context (xmallocs), it looks like it's against
something + Jim's patch. OTOH: 709f8a6 show's a get_one_entry with
mallocs. Did you hand edit the diff?
Its on top of next (d6a466e528119011d512379f7f9dfac26deb7fd9), plus
hand editing s/malloc/xmalloc/g.
Sorry for this.
Bert
For whatever reason, your patch does not apply (am) here on top of next
+ Jim's patch. Given the context (xmallocs), it looks like it's against
something + Jim's patch. OTOH: 709f8a6 show's a get_one_entry with
mallocs. Did you hand edit the diff?
Its on top of next (d6a466e528119011d512379f7f9dfac26deb7fd9), plus
hand editing s/malloc/xmalloc/g.
Sorry for this.
Bert
Signed-off-by: Bert Wesarg <redacted>
---
On Tue, Jun 16, 2009 at 12:49, Michael J Gruber[off-list ref] wrote:
> Bert Wesarg venit, vidit, dixit 16.06.2009 09:56:
>> On Tue, Jun 16, 2009 at 09:39, Michael J Gruber[off-list ref] wrote:
>>> For whatever reason, your patch does not apply (am) here on top of next
>>> + Jim's patch. Given the context (xmallocs), it looks like it's against
>>> something + Jim's patch. OTOH: 709f8a6 show's a get_one_entry with
>>> mallocs. Did you hand edit the diff?
>> Its on top of next (d6a466e528119011d512379f7f9dfac26deb7fd9), plus
>> hand editing s/malloc/xmalloc/g.
>> Sorry for this.
>>
>> Bert
>
> Junio will have to deal with it...
Here is an updated version.
Bert
builtin-remote.c | 21 ++++++++++-----------
1 files changed, 10 insertions(+), 11 deletions(-)
This causes const warnings due to the 'const' on url_str. One solution
is just s/const char/char/.
However, I think it is actually more readable to do away with url_str
entirely. The original if/else logic was much easier to follow than
realizing that url_str is initialized to NULL, and then never changed.
IOW:
if (remote->url_nr > 0) {
strbuf_addf(&url_buf, "%s (fetch)", remote->url[0]);
string_list_append(remote->name, list)->util =
strbuf_detach(&url_buf, NULL);
}
else
string_list_append(remote->name, list)->util = NULL;
And then this one is re-using url_str for a totally unrelated thing,
but could just be:
string_list_append(remote->name, list)->util =
strbuf_detach(&url_buf, NULL);
But that is somewhat nit-picking. As long as the const-warning goes
away, I will be happy enough.
-Peff
Signed-off-by: Bert Wesarg <redacted>
---
v2: - remove assigment indirection
- keep old code flow
On Mon, Jun 22, 2009 at 23:32, Jeff King [off-list ref] wrote:
> But that is somewhat nit-picking. As long as the const-warning goes
> away, I will be happy enough.
>
Thanks for the review. I have no objections to your comments and have all
incroporated into v2.
Thanks,
Bert
> -Peff
builtin-remote.c | 16 +++++++---------
1 files changed, 7 insertions(+), 9 deletions(-)