Re: [PATCH 00/23] http*: refactor (v6)
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:46:55
Tay Ray Chuan [off-list ref] writes:
Junio, this replaces the entire 'rc/http-push' topic. Changes from the previous patch series: - add a list of functions added (patch #15) - use back the die()'s like in the original (patch #16)
Thanks, will queue, but please double check the result after I push it
out, as I found some other changes not listed above, relative to what was
queued in 'pu' (I am not complaining; I am asking your extra set of
eyeballs in case I somehow screwed up applying your series to my tree).
- return value of fetch_indices() is 0 when http_get_info_packs() returns
HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);
- break the function definition of run_request_queue() by removing "void"
from the parameter list ("send out fetch requests on queue" -- no need
to resend, I fixed it up again while applying);
- update the error checking in transport.c:get_refs_via_curl() to make it
look more similar to what are in fetch_indices() in both http-push.c and
http-walker.c.
- add unused "cleanup:" label to get_refs_via_curl() in transport.c
(again no need to resend, I fixed it up while applying);
- add back a few missing "->local = NULL" I screwed up while applying the
previous series.
By the way, this is not your fault at all, but for a patch series
description, "shortlog" is a sucky way, as we can see below. When you
talk about "patch #15", the reader cannot find which one you are talking
about but has to go back to the MUA, so the list is useless for that
purpose.
The output of "shortlog" in an e-mail message is wonderful when you are a
subsystem maintainer who bundles many people's work and are sending out a
pull request (i.e. you are transferring the whole graph in "take it or
reject all" fashion, and you can refer to an individual changeset with its
commit object name).
But I think a cover letter to a patch series should serve as an easy index
from patch number to the title in some way, and "shortlog" is not suitable
for that eapecially for a multi-author series.
Christian Couder (1):
http-push: fix missing "#ifdef USE_CURL_MULTI" around
"is_running_queue"
Mike Hommey (7):
Don't expect verify_pack() callers to set pack_size
transport.c::get_refs_via_curl(): do not leak refs_url
http.c: new functions for the http API
transport.c::get_refs_via_curl(): use the new http API
http.c::http_fetch_ref(): use the new http API
http-push.c::remote_exists(): use the new http API
http-push.c::fetch_symref(): use the new http API
Tay Ray Chuan (15):
t5540-http-push: test fetching of loose objects
t5540-http-push: test fetching of packed objects
http*: cleanup slot->local after fclose
http-push: send out fetch requests on queue
t5550-http-fetch: test fetching of packed objects
http-push, http-walker: style fixes
http-walker: verify remote packs
http*: copy string returned by sha1_to_hex
http-push: do not SEGV after fetching a bad pack idx file
http*: move common variables and macros to http.[ch]
http: create function end_url_with_slash
http*: add http_get_info_packs
http: use new http API in fetch_index()
http*: add helper methods for fetching packs
http*: add helper methods for fetching objects (loose)http-push.c | 579 ++++++++--------------------------------------- http-walker.c | 533 +++++++------------------------------------ http.c | 601 +++++++++++++++++++++++++++++++++++++++++++++++-- http.h | 85 +++++++ pack-check.c | 8 +- t/t5540-http-push.sh | 36 +++ t/t5550-http-fetch.sh | 8 + transport.c | 36 ++-- 8 files changed, 905 insertions(+), 981 deletions(-)