Eric Raible [off-list ref] wrote:
Nicolas Pitre <nico <at> cam.org> writes:
quoted
On Wed, 27 May 2009, Linus Torvalds wrote:
quoted
+pack.packDeltaLimit::
+ The default maximum size of objects that we try to delta.
The option name feels a bit wrong here, like if it meant the max number
of deltas in a pack. Nothing better comes to my mind at the moment
though.
pack.maxDeltaSize sounds weird when said aloud.
How about pack.deltaMaxSize?
That sounds like, how big should a delta be? E.g. set it to 200
and any delta instruction stream over 200 bytes would be discarded,
causing the whole object to be stored instead. Which is obviously
somewhat silly, but that's the way I'd read that option...
--
Shawn.