Re: [PATCH 08/18] http*: move common variables and macros to http.[ch]
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:46:49
Tay Ray Chuan [off-list ref] writes:
*RANGE_HEADER_SIZE has been moved to http.h. *the curl header list, no_pragma_header, containing the header "Pragma:", has been created in http.[ch]. It is allocated in http_init, and freed in http_cleanup. It replaces the similarly-named variable in http-push.c, and the no_pragma_header member in walker_data in http-walker.c. *the variable http_is_verbose is created. It is intended for use by methods in http.c, and is modified at the entry points of http.c's users, namely http-push.c (when parsing options) and http-walker.c (in get_http_walker).
Again, style fix. Move RANGE_HEADER_SIZE to http.h Create the curl header list, no_pragma_header, containing the header "Pragma:" in http.[ch]. Allocate it in http_init(), and free it in http_cleanup(). ... Add http_is_verbose variable in http.c. ... I wonder if RANGE_HEADER_SIZE should be renamed to be more specific to http, but in later stages you will make it an internal implementation detail contained in http.c so it should be Ok.