Thread (2 messages) 2 messages, 2 authors, 2016-06-15

Re: [PATCH] apply: handle filenames with double slashes better

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:46:48

Possibly related (same subject, not in this thread)

Michal Marek [off-list ref] writes:
I tried this, but I'm not sure it's better now (and there might be some
inconsistencies left). IMHO removing the double slashes is an operation
similar to the unquoting done in find_name(), i.e. converting the text
in the patch to something that can be passed to lstat() or
cache_name_lookup().
Ok, you convinced me.

Let's take your first patch with just the s/canon_name/squash_slash/
change.

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help