Johannes Sixt [off-list ref] writes:
Dan McGee schrieb:
quoted
-static unsigned int hash_obj(struct object *obj, unsigned int n)
+static unsigned int hash_chars(const unsigned char *c, unsigned int n)
hash_chars suggests that this function hashes arbitrary character
sequences, but it doesn't do that. Wouldn't hash_object_id be a better
name? (And the parameter would then obviously be named sha1 or id.)
Yes, the parameter to this function is what we call "unsigned char *sha1"
everywhere else in the code. hash-object-id or hash-object-name is a good
name for the function.