Thread (2 messages) flat view 2 messages, 2 authors, 2016-06-15

Re: [PATCH] Rename core.unreliableHardlinks to core.createObject

From: Johannes Schindelin <hidden>
Date: 2016-06-15 22:46:40

Hi,

On Mon, 27 Apr 2009, Junio C Hamano wrote:
Johannes Schindelin [off-list ref] writes:
quoted
diff --git a/Makefile b/Makefile
index 5c8e83a..9ca1826 100644
--- a/Makefile
+++ b/Makefile
@@ -172,8 +172,8 @@ all::
 # information on a not yet closed file that lstat would return for the same
 # file after it was closed.
 #
-# Define UNRELIABLE_HARDLINKS if your operating systems has problems when
-# hardlinking a file to another name and unlinking the original file right
+# Define OBJECT_CREATION_USES_RENAMES if your operating systems has problems
+# when hardlinking a file to another name and unlinking the original file right
With the configuration variable for this relatively obscure feature in 
place, I wonder if we can simply get rid of the hardcoded compilation 
preference.
I'd rather not, for Windows.  Remember, it fixes issues 222 and 229.  And 
from the comments in those issues I understand that more than 2 persons 
had problems due to these issues.

Ciao,
Dscho
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help