On 0, Brian Gernhardt [off-list ref] wrote:
On Apr 5, 2009, at 12:00 AM, David Aguilar wrote:
quoted
valid_tool () {
case "$1" in
<lots-of-stuff>)
if test "$1" = "kompare" && ! diff_mode; then
return 1
fi
+ if test "$1" = "tortoisemerge" && ! merge_mode; then
+ return 1
+ fi
;; # happy
*)
if test -z "$(get_merge_tool_cmd "$1")"; then
Why is `case "$1"` being followed by two `if test "$1" =`s?
Wouldn't it be simpler to have separate case arms for them?
Especially with how long that list is getting...
~~ Brian
It would. It wasn't until after the rewrite that I remembered
this email... oh well [PATCH v2 14/14] it is
--
David