Re: [PATCH 2/2] [TopGit] Portability: Don't use alternation ("|") in sed regular expressions

From
Uwe Kleine-König <hidden>
Date
2016-06-15 22:46:23
Reply to
Brian Campbell, 2016-06-15
Hello Brian,

On Thu, Mar 12, 2009 at 12:41:45PM -0400, Brian Campbell wrote:
quoted
IMHO we should reuse as much as possible from git.git.  For me even
requiring a git.git checkout to use its files would be OK.  I consider
that even better then duplicating the relevant files.
Hmm. How would the tests find your git working tree? I'd be willing to  
start the process off at least by writing test cases for the  
functionality I'm changing here if I had a good idea of how to start.  
Would it be sufficient to make something like "GIT_CHECKOUT=~/src/git  
make check" work?
Yes, this would be a good start.  I would call it GIT_SRC, but that's up
to you.

Best regards
Uwe

-- 
Pengutronix e.K.                              | Uwe Kleine-König            |
Industrial Linux Solutions                    | http://www.pengutronix.de/  |
Thread (9 messages) 9 messages, 4 authors, 2016-06-15
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help