Jakub Narebski [off-list ref] writes:
quoted
+ # If you want a trailing slash on the project path (because, for
+ # example, you have a real directory at that URL and are using
+ # some rewrite magic to invoke gitweb), then set:
+ # $feature{'pathinfo'}{'default'} = [1, 1];
+
Are any disadvantages to having it always enabled?
Good question.
quoted
+ my @use_pathinfo = gitweb_get_feature('pathinfo');
Why not name those variables for better readability?
+ my ($use_pathinfo, $trailing_slash) = gitweb_get_feature('pathinfo');
Good suggestion.