Re: [PATCH] Add support for uintmax_t type on FreeBSD 4.9
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:45:32
"David Syzdek" [off-list ref] writes:
On Sun, Oct 26, 2008 at 9:30 PM, Junio C Hamano [off-list ref] wrote: ...quoted
I have a stupid question. Would it be a more appropriate improvement to do it like this: ifdef USE_THIS_AS_UINTMAX_T BASIC_CFLAGS += -Duintmax_t="$(USE_THIS_AS_UINTMAX_T)" endif and then add a section for FreeBSD 4.9-SECURITY like this: ifeq ($(uname_R),4.9-SECURITY) USE_THIS_AS_UINTMAX_T = uint32_t endif That way, an oddball 64-bit machine can use uint64_t here if it wants to, possibly including FreeBSD 4.9-SECURITY backported to 64-bit ;-).Your suggestion provides more flexibility for other environments. I was making the assumption that 64-bit systems would define uintmax_t, however in retrospect that would be unwise. Would you like me to resubmit the patches with your modifications?
Actually there was a reason why I said this was a "stupid" question. I
think your assumption on 64-bit platforms would hold in practice, and my
suggestion could be an unnecessary overengineering. If nobody knows of a
system that would benefit from such a generalization, your original patch
would be better, partly because I think:
(1) USE_THIS_AS_UINTMAX_T is just for demonstration of concept and is a
terrible name we cannot possibly use in our Makefile. We have to
spend brain cycles to come up with a better name; and
(2) It may be tricky to come up with autoconf macros to determine what to
set USE_THIS_AS_UINTMAX_T to.
As a slightly unrelated aside, I find it somewhat unfortunate that the
conditional says "4.9-SECURITY", which is a bit too explicit and specific.
to my taste. I do not know how FreeBSD versioning scheme works, but
wouldn't your change work equally well for 4.9-RELEASE or 4.11-RELEASE?
I suspect that you would want to say "$(uname_R) that begins with '4.' or
smaller needs this workaround", as strtoul(3) manual page seems to appear
first in FreeBSD 5.0-RELEASE (but not found in FreeBSD 4.11-RELEASE).