Thread (7 messages) flat view 7 messages, 4 authors, 2016-06-15

Re: [PATCH] Use "git_config_string" to simplify "remote.c" code in "handle_config"

From: David Bryson <hidden>
Date: 2016-06-15 22:45:26

On Fri, Oct 03, 2008 at 07:28:42AM +0200 or thereabouts, Andreas Ericsson wrote:
David Bryson wrote:
quoted
Signed-off-by: David Bryson <redacted>
I tried to keep with the naming/coding conventions that I found in
remote.c.  Feedback welcome.
---
 remote.c |   19 ++++++++++---------
 1 files changed, 10 insertions(+), 9 deletions(-)
diff --git a/remote.c b/remote.c
index 3f3c789..893a739 100644
--- a/remote.c
+++ b/remote.c
@@ -305,6 +305,7 @@ static int handle_config(const char *key, const char 
*value, void *cb)
 {
 	const char *name;
 	const char *subkey;
+	const char *v;

Not very mnemonic. I'm sure you can think up a better name, even if it's
a long one. Git is notoriously sparse when it comes to comments. We rely
instead on self-explanatory code.
Oh I agree entirely, it is quite vague, however like I mentioned I tried
to keep to the conventios in the file.  This strategy(v) is used in several
other places in remote.c, if this is Bad Code, then I have no problem
changing it.

Thoughts from anybody else ?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help