On Mon, Sep 29, 2008 at 08:34:00AM -0700, Shawn O. Pearce wrote:
Johannes Sixt [off-list ref] wrote:
quoted
My point is that emphasis on "stat" in the name is wrong: That's about
implementation, but not about the effect. Why wouldn't 'ignoreCygwinFSTricks'
be specific enough?
I like this a lot better. I could see us also bypassing other Cygwin
functions like open() in order to get faster system calls for Git.
If you think that it may be useful to bypass some other functions, and
you want to use the same option to control that then a general name like
that makes sense. Personally, I don't believe that we may want to bypass
something like open() as it is not performance critical, but I said
above I don't care about the name much, so I am going to change my patch
to use ignoreCygwinFSTricks.
Dmitry