Thread (2 messages) flat view 2 messages, 2 authors, 2016-06-15

Re: [PATCH] Replace "git-" with "git " in *.[ch] comments and notifications

From: Heikki Orsila <hidden>
Date: 2016-06-15 22:45:15

On Fri, Aug 29, 2008 at 05:56:58PM -0700, Junio C Hamano wrote:
Heikki Orsila [off-list ref] writes:
quoted
diff --git a/archive.c b/archive.c
index e2280df..042f587 100644
--- a/archive.c
+++ b/archive.c
@@ -282,7 +282,7 @@ static int parse_archive_args(int argc, const char **argv,
 		OPT_STRING(0, "remote", &remote, "repo",
 			"retrieve the archive from remote repository <repo>"),
 		OPT_STRING(0, "exec", &exec, "cmd",
-			"path to the remote git-upload-archive command"),
+			"path to the remote git upload-archive command"),
 		OPT_END()
 	};
Are you sure about this one?  How would one spell the command line?

	$ git archive --exec='/usr/local/bin/git upload-archive'

I somehow think this wouldn't fly well.

I do not think a single patch with the above hunk (which I think is a
mistake) and other bits that are obviously good (e.g. the first hunk to
builtin-apply.c we see below) is reviewable, but I cannot think of a
better alterantive.  Sigh...
OK, wherever git-receive-pack, git-upload-archive or 
git-upload-back was changed to the new form, I changed it back. These 
are afaik the last 3 git-* commands in bindir.
quoted
@@ -506,17 +506,17 @@ static char *gitdiff_verify_name(const char *line, int isnull, char *orig_name,
 		name = orig_name;
 		len = strlen(name);
 		if (isnull)
-			die("git-apply: bad git-diff - expected /dev/null, got %s on line %d", name, linenr);
+			die("git apply: bad git diff - expected /dev/null, got %s on line %d", name, linenr);
 		another = find_name(line, NULL, p_value, TERM_TAB);
 		if (!another || memcmp(another, name, len))
-			die("git-apply: bad git-diff - inconsistent %s filename on line %d", oldnew, linenr);
+			die("git apply: bad git diff - inconsistent %s filename on line %d", oldnew, linenr);
I am not sure about this one.  This is not talking about the git-diff
program, but about a variant of "diff" with git flavour (similar to the
word "unified diff" -- there is no "unified" command with subcommand
"diff").   So rolling this kind fo change into a topic that tries to get
rid of "dashed form of commands" feels quite wrong, even though as a
general wording improvement, I think it is better than the original (and I
would even suggest rewording to "git patch", to make sure we are not
talking about the "git-diff" program).
I'll change it back to git-diff, but retain "git apply".
I did not look at the rest.
Is the concept OK for this change? I can submit another patch.

-- 
Heikki Orsila
heikki.orsila@iki.fi
http://www.iki.fi/shd
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help