On Tue, May 27, 2008 at 10:08:01AM -0400, Kristian H?gsberg [off-list ref] wrote:
quoted
-int reset_index_file(const unsigned char *sha1, int is_hard_reset)
+int reset_index_file(const unsigned char *sha1, int is_hard_reset, int verbose)
I would suggest using flags here instead of a bunch of boolean args.
Consider the readability of
reset_index_file(sha1, 1, 1);
vs
reset_index_file(sha1, RESET_HARD | RESET_VERBOSE);
Thanks for the suggestion, but - as Daniel already pointed out - the
same functionality can be achieved by using the unpack_trees() API
directly, so the patch is useless.