On Fri, May 23, 2008 at 08:12:31PM +0200, Florian Köberle [off-list ref] wrote:
Also it is better extenable:
if (a) {
something0();
}
if (a) {
something0():
+ something1();
}
compared too:
-if (a)
+if (a) {
something0();
+ something1();
+ }
it's even possible that someone does it wrong:
if (a)
something0():
something1();
Different programmers have different coding style. A standard is needed,
otherwise different parts of the code will have different style. It's
quite normal if a contributor has to code in the project's coding style,
rather than his own one, I think.
Also I don't think "but this style is confusing for newbies" is a valid
argument, newbies should learn to read code, rather than others need to
write newbie-friendly code. ;-)