Hi,
On Fri, 14 Mar 2008, Ping Yin wrote:
I find it is so annoying to write submodule definition as follows
(yeah, only url, without path)
------------------------------
[submodule 'crawler']
url = url1
[submodule 'search']
url = url2
------------------------------
I think the following form is more simple
---------------------------------
[submodule]
crawler.url = url1
search.url = url2
---------------------------------
So, could we support such simpler form?
I don't like it at all. Historically, we had much stricter rules on the
variable names than the second part of the section names.
Also, your suggestion would make things even more confusing than beginners
already complain Git is.
Ciao,
Dscho