On Tue, Mar 11, 2008 at 8:27 PM, Johannes Schindelin
[off-list ref] wrote:
Hi,
On Sun, 2 Mar 2008, Nguyễn Thái Ngọc Duy wrote:
> worktree setup inside setup_git_directory*() is not perfect. It does not
> take core.worktree into account. So when you do setup_work_tree(), the
> real work tree may be not the one setup_git_directory*() gives you. You
> need a new prefix in that case.
Probably the real fix would be to setup_git_directory(), no?
setup_work_tree() does the job fine. Why duplicate the code one more?
In the old days, setup_git_directory() was just a simple wrapper
around setup_git_dir_gently(). I wanted to move it back to those days.
And setup_git_directory() is fixed in "Completely move out worktree
setup from setup_git_directory_gently()" so setup_git_directory() does
contain the real fix in the end.
Ciao,
Dscho
--
Duy