Hi,
On Thu, 7 Feb 2008, Jay Soffian wrote:
On Feb 7, 2008 12:13 AM, Jeff King [off-list ref] wrote:
quoted
On Wed, Feb 06, 2008 at 12:59:32PM -0800, Junio C Hamano wrote:
quoted
I was tempted to suggest GIT_WORK_TREE=/dev/null because that is
what "diff" uses to mark "this does not even exist", but that
feels dirty.
It feels dirty to me, too. I would rather choose something that doesn't
even look like a path. I think GIT_WORK_TREE=" " is too ugly, too.
Is using something like "__GIT_WORK_TREE_NOT_SET__" that terrible?
Yes. First: it looks more like a C constant than a proper environment
variable. Second: what to do _sanely_, when both GIT_WORK_TREE and
GIT_WORK_TREE_NOT_SET are true?
Of course, you could argue that one should override the other. But the
consequence will be user errors that could be prevented, thus it is a
design error.
Ciao,
Dscho