Jari Aalto [off-list ref] writes:
Change (list|...) to <list|...> to denote required command. Adjust
the 'save' command syntax to better reflect the call parameters:
[save] [message...] => [save [message...]].
While I agree with the second change, i.e. the "[save [message...]]"
part, I think that the first part is a mistake. Parentheses does not
imply the optional part: brackets do; parentheses are meant to
delimit the alternatives. Angle brackets if I understand correctly
are meant to denote part which you have to enter, the user supplied
info (the reast ou have to enter literally).
So IMVHO the SYNOPSIS for git-stash(1) should read:
SYNOPSIS
--------
[verse]
'git-stash' (list | show [<stash>] | apply [<stash>] | clear)
'git-stash' [save [<message>...]]
or
'git-stash' [save [<message...>]]
--
Welcome to FOSS revolution: we fix and modify until it shines
Nice one. Can I add it to http://git.or.cz/gitwiki/FortuneCookies ?
--
Jakub Narebski
Poland
ShadeHawk on #git