Jakub Narebski [off-list ref] writes:
"git diff --numstat" used the same format as "git diff --stat" for
renamed (and copied) files, except that filenames were not shortened
when they didn't fit in the column width. This format is suitable for
human consumption, but it cannot be unambiguously parsed.
Agreed about the (un)parsability, and --numstat is all about parsability
so I would not object. A fix is really needed there.
I do not have time to look at the patch right now, but if the changed
output is in line with what --name-status would show, that would be
great. I'd call that "the format that should have been from day one".
I.e. no '=>' rename marker, but show two names c-quoted (unless -z is
used) and separated with inter_name_termination). IIRC, that is how
rename/copy is shown with --name-status.